Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. Make sure the SRM environment variable "bootdef_dev" is NOT set. If the "bootdef_dev" variable points to your target system disk, the CDROM boot procedure will attempt to use the existing PHDB.
    P00>>>set bootdef_dev ""
  2. Boot from the Tru64 installation CDROM
    P00>>>boot dkaXXX
  3. Mount the target system disk root partition
    (assumption: AdvFS)
    # cd /etc/fdmns
    mkdir root
    # hwmgr show scsi
    (identify target system disk. example: "/dev/disk/dsk0")
    # ln -s /dev/disk/dsk0a root/
    # mkdir /tmp/root
    # mount root#root /tmp/root
  4. Clean up old PHDB files
    # cd /tmp/root/etc
    # rm -f dec* df* dc* cfginfo
    # rm -f /tmp/root/cluster/members/member/etc/df*
    # rm -f /tmp/root/cluster/members/member/.Booted
  5. Unmount target root fileset
    # cd /
    # umount /tmp/root
  6. Halt in-memory (CDROM-based) system
    # halt
  7. Boot from target disk in single-user mode
    (This is the point at which the new PHDB is created)
    P00>>>boot -fl s -fi genvmunix dkaX
  8. Mount root fileset read/write (you will see messages indicating a new PHDB is being created)
    # mountroot
  9. Fix Advfs symbolic links
    # hwmgr show scsi
    (identify target system disk. Example: "/dev/disk/dsk0")
    # cd /etc/fdmns
    # rm root_domain/* usr_domain/*
    # ln -s /dev/disk/dsk0a root_domain/
    # ln -s /dev/disk/dsk0g usr_domain/
  10. Mount all filesystems
    # bcheckrc
  11. Fix swap in /etc/sysconfigtab
    vm:
      swapdevice = /dev/disk/dsk0b
  12. Build new kernel
    # doconfig -a

...